Страница печати | Закрыть окно

Слетает активация VMWARE ESXi

Распечатать форум: Форум компании Смарт-Софт
Категория: Главный раздел
Название форума: Traffic Inspector - бета тестирование
Описание форума: Вопросы, связанные с тестированием предварительных версий.
URL: http://forum.smart-soft.ru/forum_posts.asp?TID=18305
Дата печати: 20-Апр-19 в 09:38
Версия ПО: Web Wiz Forums 10.14 - http://www.webwizforums.com


Тема: Слетает активация VMWARE ESXi
Автор: xfantomx
Тема: Слетает активация VMWARE ESXi
Дата отправки: 08-Апр-09 в 15:54
Administrator написал:Проверьте, отписывается ли после активации на диск файл Lic.cer. Если да, то проблема скорее всего в том, что после перезагрузки VMWare меняется конфигурация железа. Тут имеется ввиду не железо самого сервера, а то, что WMWare предоставляет в виртульной среде. При активации есть запрос на смену железа ?

Новый файл Lic.cer создается всегда. Пробовал удалять после активации он появляется вновь. Запрос на обновление конфигурации есть, ID=21500. Для того чтобы активация слетела достаточно остановить службу и запустить вновь без перезагрузки сервера.



Ответов:
Автор: LBVF
Дата отправки: 15-Апр-09 в 16:29

Подтверждаю проблему.

Traffic Inspector сборки 1.1.6.610b3 после временной активации в виртуальной машине VMWare Server 1.0.8 слетает в режим DEMO после перезагрузки виртуалки, а так же если просто перестартовать сервис Traffic Inspector. Файл Lic.cer успешно создается.

В виртуалке крутится Windows 2003 Std Rus со всеми последними сервиспаками и обновлениями.



Автор: TKFK
Дата отправки: 08-Май-09 в 18:34
Та же проблема...
Никуда не годится такое ограничения...
VMware ESX Server 3.5 Update 4 + Windows 2003 Std Rus + Traffic Inspector 1.1.6.612 = Demo после перезапуска службы...
Временная активация работает....
Что скажут разработчики?



Автор: Vander
Дата отправки: 10-Май-09 в 10:48
Вот только по этому еще не воткнул ТИ на ESXi.
Очень хочется чтобы эта проблема была решена....

Тогда шлюз разберу.. оперативку на сервер переставлю...мммм мечты....


Автор: Enzain
Дата отправки: 12-Май-09 в 05:53

привязка к процу и материнке идет, скорее всего меняется какая то инфа после ребута, тут если только активацию переделывать ... но это как говорится ИМХО



-------------
Win 2k3 R2
Win 2k8 R2

TI Последняя версия

http://fw.enzain.ru/" rel="nofollow - списки категорий контента - по функционалу в аську 301367164.


Автор: TKFK
Дата отправки: 12-Май-09 в 08:00
Исходное сообщение Enzain Enzain :

привязка к процу и материнке идет, скорее всего меняется какая то инфа после ребута, тут если только активацию переделывать ... но это как говорится ИМХО

Как бы узнать какая именно меняется?
Есть в ESX настройка виртуальной машины CPU ID Mask попробую сегодня поковырять её...

Ничего не получилось у меня, но если ставлю Hide ID Mask, то вообще не активируется, хотя толком времени не было по разбираться...


Автор: xfantomx
Дата отправки: 02-Июн-09 в 10:58
Ну что подправили для работы на VMWare server? А то уже релиз кандидат вышел и пока что тишина. Сервер стоит и ждет Traffic Inspector.


Автор: Default
Дата отправки: 02-Июн-09 в 11:13
а постоянная активация отваливается?



Автор: xfantomx
Дата отправки: 02-Июн-09 в 11:44
Последний rc не проверял. А так да отваливалась. И даже временная, активирую Traffic Inspector оставнавливаю сервис, запускаю и активация слетает.


Автор: avs
Дата отправки: 02-Июн-09 в 13:13
Default,
у нас TI GOLD на VMWARE SERVER 2.0 при перезапуске вирт машины отваливается активация как временная, так и постоянная.


Автор: TKFK
Дата отправки: 30-Июн-09 в 06:07
Разработчики!
Пожалуйста, скажите что нужно сделать, чтобы история с активацией под VMware сдвинулась уже с мёртвой точки?


Автор: neoplan
Дата отправки: 30-Июн-09 в 10:15
Мне тоже ОЧЕНЬ интересен комментарий смарт-софта.


Автор: Default
Дата отправки: 30-Июн-09 в 10:22
сам лично использую VMWare WorkStation 6.0.4
проблем с активацией нет.

ТИ не делает различий между виртуальной и обычной машиной, а сбой активации может быть связан только с тем, что после перезагрузки меняется информация о железе, к которым идет привязка.


Автор: TKFK
Дата отправки: 30-Июн-09 в 13:35
Default,
Согласен, активируется, проблема в сохранении активации после перезагрузки. У Вас на VMWare WorkStation 6.0.4 активация после перезагрузки сохраняется?


Автор: Default
Дата отправки: 30-Июн-09 в 14:13
да, сохраняется.


Автор: xfantomx
Дата отправки: 30-Июн-09 в 17:48
Т.е тем кто использует VMServer можно сушить весла? Инспектор у нас работать не будет?


Автор: TKFK
Дата отправки: 01-Июл-09 в 07:59
Исходное сообщение xfantomx xfantomx :

Т.е тем кто использует VMServer можно сушить весла? Инспектор у нас работать не будет?

+ тем кто использует VMware ESXi?


Автор: neoplan
Дата отправки: 01-Июл-09 в 08:10
Исходное сообщение Default Default :

сам лично использую VMWare WorkStation 6.0.4проблем с активацией нет.

а можете лично попробовать на ESX ? ведь это основная платформа виртуализации.


Автор: xfantomx
Дата отправки: 01-Июл-09 в 11:38
Я пробовал на ESXi. Слетает.


Автор: _phoenix_
Дата отправки: 01-Июл-09 в 16:59

Исходное сообщение Default Default :

сам лично использую VMWare WorkStation 6.0.4
проблем с активацией нет.

ТИ не делает различий между виртуальной и обычной машиной, а сбой активации может быть связан только с тем, что после перезагрузки меняется информация о железе, к которым идет привязка.

Ничего подобного. Активация слетает так же при перезапуске службы TI, даже без перезагрузки гостевой машины.  И, кстати, и в том и другом случае(перезагрузка и перезапуск службы), иногда активация не слетает))

 



Автор: neoplan
Дата отправки: 01-Июл-09 в 21:24
У меня такое чувство, что после выхода релиза мы быстрее дождемся решения от руборда чем от смартсофта.
Господа разработчики ответь пожалуйста на пару вопросов:
1)проблема с изменением активацию на "demo",после рестарта службы TI в виртуальных машинах Вам ИЗВЕСТНА и признана как БАГ ?
2)если вам проблема известна, то как она будет решатся?
3)если проблема будет решатся то в какой срок? 3\6\12\24 месяца ?

Т.к. форум это официальный способ техподдержки, то хотелось бы услышать ответ от компании по всем трем вопросам.


P.S.если у вас есть трудности с ESX, мы можем вам дать информацию как поставить ESX\ESXi на обычный сервер типа hp ML. Также мы готовы нарезать для вас vm c белым ip и дать к ней удаленный доступ.

Алеша Пирожков
icq:176-203-930
neoplanza(coбака)list.ru


Автор: _phoenix_
Дата отправки: 02-Июл-09 в 09:11

Скажите хотябы, как с помощью скриптов переактивировать? Чтобы поставить в задачу, при рестарте произвести активацию.



Автор: Administrator
Дата отправки: 02-Июл-09 в 10:36

Мы уже отвечали, что проблема в том, что после перезагрузки данной виртуальной машины меняется "железное" окружение. Отсюда слетает активация.

Нашим багом это назвать трудно. Переделывать активацию в плане ослабления защиты мы не будем, так как это может повлечь появление "подарков" для соотв. публики.

С WMWare Server таких проблем нет. Для ESX\ESXi тема требует серьезного изучения, вполне возможно, что на каких-то версиях это все будет работать нормально. Сроки пока назвать не можем.

 



Автор: Administrator
Дата отправки: 02-Июл-09 в 10:37
Исходное сообщение _phoenix_ _phoenix_ :

Скажите хотябы, как с помощью скриптов переактивировать? Чтобы поставить в задачу, при рестарте произвести активацию.

Это можно, скрипт вышлем.

 



Автор: xfantomx
Дата отправки: 02-Июл-09 в 10:52
У нас ведь вроде всего 3 активации, 3 перезагрузки и сервер лежит! или будет безлимитное количество активаций?


Автор: _phoenix_
Дата отправки: 02-Июл-09 в 11:14
Исходное сообщение Administrator Administrator :

Мы уже отвечали, что проблема в том, что после перезагрузки данной виртуальной машины меняется "железное" окружение. Отсюда слетает активация.

Нашим багом это назвать трудно. Переделывать активацию в плане ослабления защиты мы не будем, так как это может повлечь появление "подарков" для соотв. публики.

С WMWare Server таких проблем нет. Для ESX\ESXi тема требует серьезного изучения, вполне возможно, что на каких-то версиях это все будет работать нормально. Сроки пока назвать не можем.

 

Всеравно непонятно, почему пи перезапуске слжбы слетает активация???? ESX 'нелету' оборудование менят?



Автор: Default
Дата отправки: 02-Июл-09 в 11:22
скрипт активации

' (C) SMART-SOFT 2009
' VBScript script demo
' --------------------


Set Args = WScript.Arguments.Unnamed
If Args.Count <> 2 Then
    WScript.Echo "??? usage: cscript.exe Activate.vbs AdmID AdmPass /sn:ServerName"    
    WScript.Quit    
End If

AdmID = Args(0)
AdmPass = Args(1)
    
Contract  = 99999999  ' ID продукта (8 цифр). Если используется триал, то "0"
PIN1 = 9999           ' PIN1 (4 цифры). Если используется триал, то "0"
PIN2 = 99999999       ' PIN2 (8 цифр). Если используется триал, то "0"

If WScript.Arguments.Named.Exists("sn") Then
    ServName = WScript.Arguments.Named.Item("sn")
    Set Srv = CreateObject("TrafInsp.TrafInspAdmin", ServName)
Else
    Set Srv = CreateObject("TrafInsp.TrafInspAdmin")
End If
Set Perm = Srv.QueryPermissions()
LogOn = Perm.DoSharedLogon(AdmID, AdmPass, "Script")

Res=Srv.Activate(Contract, PIN1, PIN2, -1)
If Res>0 then
  WScript.Echo "Ошибка активации программы " & Res
end if
 


Автор: Default
Дата отправки: 02-Июл-09 в 11:24

Исходное сообщение xfantomx xfantomx :

У нас ведь вроде всего 3 активации, 3 перезагрузки и сервер лежит! или будет безлимитное количество активаций?
а у вас каждый раз новая привязка по железу?



Автор: TKFK
Дата отправки: 08-Июл-09 в 06:55
Default,
Спасибо за скрипт активации, пока пускай активируется после перезагрузки.
А каким образом узнать, что именно изменяется, по мнению ТИ, после перезагрузки, для того чтобы разбираться уже с VMware?


Автор: xfantomx
Дата отправки: 08-Июл-09 в 14:23
Обновил свой ESXi до 4 версии. Трафик инспектор завелся и активация после перезагрузки не слетает. Операционка XP Prof SP3 трафик инспектор последняя бета.


Автор: _phoenix_
Дата отправки: 24-Авг-09 в 10:00

Исходное сообщение xfantomx xfantomx :

Обновил свой ESXi до 4 версии. Трафик инспектор завелся и активация после перезагрузки не слетает. Операционка XP Prof SP3 трафик инспектор последняя бета.

50/50 Иногда слетает, иногда нет.

Сделайте уже чтонибудь, плиз. Или количество переактиваций увеличте, чтобы можно было скриптом при перезагрузке активировать.



Автор: Uns
Дата отправки: 01-Сен-09 в 12:40
_phoenix_ а зачем сервер часто перегружать ?
у меня годами работает без перезагрузки


Автор: _phoenix_
Дата отправки: 01-Сен-09 в 14:07

Исходное сообщение Uns Uns :

_phoenix_ а зачем сервер часто перегружать ?
у меня годами работает без перезагрузки

Обновления значитне ставите?

 



Автор: Uns
Дата отправки: 03-Сен-09 в 12:38
_phoenix_ такое бывает 1 раз в месяц не чаще.
и то после тестирования установки новых обновлений на тестовом сервере. не все обновления одинаково полезны


Автор: _phoenix_
Дата отправки: 03-Сен-09 в 13:21

Исходное сообщение Uns Uns :

_phoenix_ такое бывает 1 раз в месяц не чаще.
и то после тестирования установки новых обновлений на тестовом сервере. не все обновления одинаково полезны

дак всетаки годами или раз в месяц?

Как бы то нибыло, проблема есть, нужно ее решать, не важно как часто кто перезагружается.



Автор: Rakel'
Дата отправки: 11-Янв-10 в 16:19
опробовано на ESXi 4U1

Активация возвращается после нескольких перезапусков сервиса (иногда через один). Это максимальный эффект, которого можно добиться... и то только если предоставить гостевой системе все процессора.

Все в напряжении ждут, когда Старсофт (или Смартфорс) уберет баррикады на пути прогресса.


Update:
VMware Server Version 2.0.2 под Линуксом. АКТИВАЦИЯ СЛЕТАЕТ!


Автор: brass_net
Дата отправки: 15-Янв-10 в 12:23
А что у вас стоит в настройках сетевухи, назначение MAC каким образом происходит? Может оттуда рога растут со сменой железа и слета активации...   IMHO




-------------
Forti Gate + Zentyal + 10Mbit Fiber + 6Mbit Ethernet.


Автор: xfantomx
Дата отправки: 18-Янв-10 в 16:38
У меня в ESXi 4 работает как часики уже раз 100 перезагружал ни разу не слетела. Дело навряд ли в мак адресе я там ничего не менял. У меня давно еще была трабла со временем. В настройках виртуальной машины можно поставить галку вроде что бы она синхронизировала часы с гипервизором. У меня она стояла а на гипервизоре время было неточное. В итоге из за несовпадения времени активация и слетала, потом я галку эту убрал и все стало отлично.


Автор: brass_net
Дата отправки: 18-Янв-10 в 23:34
Лучше выставить синхронизацию времени по NTP, я на своих ESX что-то атк и не смог заставить машины брать время с гипервизора, все время были траблы, по советам с форумов вмвари поставил NTP.

-------------
Forti Gate + Zentyal + 10Mbit Fiber + 6Mbit Ethernet.


Автор: Rakel'
Дата отправки: 30-Мар-10 в 18:17
Адекватной работы удалось добиться только после выделения ВМ исключительно одного процессора



В таком виде работает... но, вы сами подумайте, работать на одном проце, в системе, где не только ресурсолюбивый ТИ находится, но ведь еще и MSSQL завести надо... и не просто данные в него пихать, но еще и отчёты строить по выборке... Вобщем вариант на костылях меня не устраивает. Ждём чего-то полностью работоспособного


Update:
"Произошли изменения в системе активации, обновите версии 2.0.0 до 2.0.0.632 сборки, версии 1.1.5 - до 1.1.5.225. "
Скачал ... в архиве инсталлятор 632 от 19 марта, 225 от 11 марта)
Обновил ... активация держится только на на одном проце.


Автор: MGren
Дата отправки: 14-Апр-11 в 10:32
ESXi 4.1 Update1, Win Server 2008 R2 SP1, TI 2.0.1.711b1 Gold Unlimited - активация после перезагрузки и хоста, и гостя слетает.

В 2011 году что-то поменяется? И какое число переактиваций у ключа?

И по скрипту на 3-й странице темы - малость непонятно как его в планировщике запускать, какие аргументы менять...



Автор: Rakel'
Дата отправки: 16-Дек-11 в 10:57
Активация ТИ в ESXi привязывается к процу и слетает при ребуте - это однозначно выяснено в ходе экспериментов.
Мне тут подумалось, что проще не переактивировать ТИ, а ловить через АПИ режим активации Демо\НеДемо (если это возможно), и тупо рестартить сервис до посинения, пока активация не вернется на родину.

Question Может кто скрипт накорябает под это?! Wink


Автор: MGren
Дата отправки: 19-Дек-11 в 09:47

Раз уж подняли тему. Иногда при перезагрузке активация не слетает. К томуж переактивироваться не требуется - достаточно просто перезагрузить службу ТИ. В крайнем случае перезагрузиться второй раз.

И предложение к разработчикам... раз уж проблему нельзя решить. Чтоб админам было спокойнее и при перезагрузке через радмин случайно не потерять связь с сервером из-за того, что он вошел в демонстрационный режим можно сделать какую-то настройку, чтобы в этом демонстрационном режиме могли работать три конкретных пользователя (определяемых админом), а не самых активных? И вопрос - в демонстрационном режиме работу удаленный доступ к самому серверу сохраняется?.. а то небыло возможности проверить.



Автор: DanilaT
Дата отправки: 19-Дек-11 в 10:27
В деморежиме работают первые 3 по списку в мониторе работы при сортировке по отображаемому имени.

-------------
Техническая поддержка
Тел. (495)77-55-991, (4966)15-49-21
E-mail: support(coбака)smart-soft.ru


Автор: Rakel'
Дата отправки: 19-Дек-11 в 11:46
Исходное сообщение MGren MGren :

в демонстрационном режиме работу удаленный доступ к самому серверу сохраняется?

Это можно решить фильтрами на разрешение "Для всех".

UP: Что насчёт скрипта?


Автор: MGren
Дата отправки: 20-Дек-11 в 09:07
Какими конкретно фильтрами? У меня версия 2.0.1.711


Автор: Rakel'
Дата отправки: 20-Дек-11 в 10:52
я 2 ветку в глаза не видел. В 1.1.5.* это было:
"Внутренние сети" - "общие фильтры" - "разрешения для всех"

P.S. сорри за офф


Автор: MGren
Дата отправки: 22-Май-13 в 13:56

На заметку разработчикам. Переходил на новую версию ТИ, тестировал с различным виртуальным оборудованием и активировался во время тестов временной активацией. В общем наблюдения такие:

1. По каким-то причинам с сетевыми адаптерами VMXNET3 под конец рабочего дня начинаются затыки, скорость с самого сервера где стоит ТИ падает, после перезагрузки все норм. Нормальная скорость - 80-90 Мбит, падает до 10-15 Мбит. Число пользователей под 400, авторизованных 300, активных по трафику 80-90.

2. Если изменять раз в месяц конфиг виртуального оборудования (добавлять/убавлять ядра и т.п.), то на временной активации можно жить ооочень долго если не всегда. Это к вопросу о том, что у вас там хитрый механизм для постоянной активации, который вы не хотите менять и который периодически может сбоить если ТИ расположен в ВМ.



Автор: DanilaT
Дата отправки: 22-Май-13 в 14:34
Исходное сообщение MGren MGren :

На заметку разработчикам. Переходил на новую версию ТИ, тестировал с различным виртуальным оборудованием и активировался во время тестов временной активацией. В общем наблюдения такие:

1. По каким-то причинам с сетевыми адаптерами VMXNET3 под конец рабочего дня начинаются затыки, скорость с самого сервера где стоит ТИ падает, после перезагрузки все норм. Нормальная скорость - 80-90 Мбит, падает до 10-15 Мбит. Число пользователей под 400, авторизованных 300, активных по трафику 80-90.

2. Если изменять раз в месяц конфиг виртуального оборудования (добавлять/убавлять ядра и т.п.), то на временной активации можно жить ооочень долго если не всегда. Это к вопросу о том, что у вас там хитрый механизм для постоянной активации, который вы не хотите менять и который периодически может сбоить если ТИ расположен в ВМ.

1 - пользователи прокси не используют? ОС какая? Какой NDIS драйвер?

2 - это нормально, можете хоть 2 раза в месяц менять конфигурацию оборудования и использовать Trial.



-------------
Техническая поддержка
Тел. (495)77-55-991, (4966)15-49-21
E-mail: support(coбака)smart-soft.ru



Страница печати | Закрыть окно