Страница печати | Закрыть окно

Переход с 2003 на 2008-2012 Nat не работает

Распечатать форум: Форум компании Смарт-Софт
Категория: Другие
Название форума: Общие вопросы по Сетям
Описание форума: Обсуждение различных решений для построения сетей.
URL: http://forum.smart-soft.ru/forum_posts.asp?TID=22012
Дата печати: 20-Апр-19 в 20:04
Версия ПО: Web Wiz Forums 10.14 - http://www.webwizforums.com


Тема: Переход с 2003 на 2008-2012 Nat не работает
Автор: fix
Тема: Переход с 2003 на 2008-2012 Nat не работает
Дата отправки: 23-Ноя-11 в 18:54
Добрый день!
Решил шлюз перевести с Windows server 2003 на Windows server 2008 r2 enterprise
И столкнулся с проблемой.
Суть проблемы:
Имеются 2 интерфейса, 1 смотрит в локальную сеть, 2ой в инет.
Поднимаю службу маршрутизации настраиваю нат(не устанавливая TI)
И по сути инет на клиентских машинах должен пойти, по крайне мере так на 2003 сервере.
А инета нет на клиентских машинах, т.е серв 2008 не раздает интернет.
А на самом сервере интернет есть.
Уже все перепробовал, отключал брандмауэр(правила, службы)
Настраивал брандмауэр, создовал правила для исходящих\входящих подключений, включал правила "Доступ к сети COM+"
После установки TI ничего не меняется.
Помогите решить проблему пожалуйста.






Ответов:
Автор: mr_Neo
Дата отправки: 23-Ноя-11 в 20:06
Исходное сообщение fix fix :


Уже все перепробовал
вы бы хоть настройки обоих интерфейсов сервера и клиентской машины привели, что показывает трасерт в мир, что показывает nslookup ya.ru, ринг в мир по ip.,
а так у вас одни слова, спасите помогите кто может...


-------------
Win2003ServerSP2 в режиме роутера, DNS, TIGold224, сеть без домена, авторизация через агента (IP+Log+pass), QoS на Микротике x86 (4 внешних канала).


Автор: fix
Дата отправки: 24-Ноя-11 в 08:02
Интерфейс локальной сети:
192.168.1.4
255.255.0.0
Интерфейс интерната:
82.151.21*.*
255.255.255.192
82.151.21*.*
Днс
217.24.176.30
217.24.177.2

NAT:

82.151.21*.*
255.255.255.192
82.151.21*.*
Клиенты:
192.168.0.0\254-192.168.1.0\254
255.255.0.0

Нслукап и трасерт ничего не показывают у клиентов.

А когда удаляю в нате пул адресов выдаваемых провайдером, инет идет на клиентов.
Настраивал Нат по видео и по факу с сайта смарт-софта
На 2003 сервере, так же все настраивал и проблем не было.
Прошу помощи.


Автор: ivan101
Дата отправки: 24-Ноя-11 в 08:53
пропишите все внешние айпишники на интерфесе "NAT:"

-------------
TI 1.1.5.224 -> TI 2.0.0.644


Автор: fix
Дата отправки: 24-Ноя-11 в 09:07

82.151.21*
255.255.255.192
82.151.21*



Автор: ivan101
Дата отправки: 24-Ноя-11 в 10:08
я имел ввиду что весь пул надо забить руками во внешний интерфейс сервака
и в резервировании каждому внешнему ип сопоставить частный
только тогда всё заработает

то есть внешняя сетевуха сервака будет иметь кучу айпи адресов

понятно?


-------------
TI 1.1.5.224 -> TI 2.0.0.644


Автор: fix
Дата отправки: 24-Ноя-11 в 10:32
Понятно, все ровно не работает :(
У меня в сети около 80 машин которые имеют доступ в инет, а провайдер выдает 60 айпи
Нат должен радовать автоматом айпи
Что же не дает работать нату?


Автор: ivan101
Дата отправки: 24-Ноя-11 в 10:36
хз я сделал так как в здесь
  http://forum.smart-soft.ru/forum_posts.asp?TID=21991&PID=160007&title=traffic-inspector-nat#160007" rel="nofollow - http://forum.smart-soft.ru/forum_posts.asp?TID=21991&PID=160007&title=traffic-inspector-nat#160007
-  работает


-------------
TI 1.1.5.224 -> TI 2.0.0.644


Автор: fix
Дата отправки: 24-Ноя-11 в 14:09
Обратился за помощью в тех поддержку, мне ответили что они не знают как настраивать ТИ с пулом адресов.
Народ подскажите пожалуйста, наверняка у кого то стоит 2008 серв и провайдер выдает свой пул адресов.
И вы сталкивались с такой же проблемой


Автор: ivan101
Дата отправки: 24-Ноя-11 в 14:13
я же выше написал как.
только вот что делать если не хватает айпишников в пуле я хз.
пиши в майкрософт. расскажешь что они говорят


-------------
TI 1.1.5.224 -> TI 2.0.0.644


Автор: PMaikl
Дата отправки: 30-Янв-12 в 07:57
Исходное сообщение fix fix :

NAT:

82.151.21*.*
255.255.255.192
82.151.21*.*
Клиенты:
192.168.0.0\254-192.168.1.0\254
255.255.0.0

У вас маска подсети другая

Исходное сообщение fix fix :

Интерфейс локальной сети: 
192.168.1.4
255.255.0.0



Автор: fix
Дата отправки: 09-Фев-12 в 16:59
переделал маску

NAT:

82.151.21*.*
255.255.255.192
82.151.21*.*

Интерфейс локальной сети(на шлюзе): 
192.168.0.4
255.255.255.0


клиент
192.168.0.86
255.255.255.0

Ничего не изменилось.
И как только в маршрутизации в преоброзование сетевых адресов (NAT) в интерфейсе инета удаляю пул адресов инет идет на клиенте, причем шлюз присваевает клинту свой ип
че за фигня, уже голову сломал :(


Автор: fix
Дата отправки: 16-Фев-12 в 16:45
Опишу настройку со скринами
Значит поднимаем 2008 серв
Поднимаем роль политики сети и доступа
Включаем маршрутизацию

Выбираем особая конфигурация


Далее


Все поднято


Добавляем интерфейсы в НАТ с начало локалка




Теперь интерфейс интернета и включаем его в нат



Все интернет на клиенте пошел
Трассерт с е1.ру с клиента


Трассерт на е1.ру с сервера шлюз



Добавляем в нате в интерфейс интернета пул адресов выделяемый провайдером





Все инет на клиенте пропал, на шлюзе есть! А как только пул удаляешь инет на клиентов идет, но клиент выходит в инет через внешний Ип шлюза 82.151.*.2
Трассерт на е1


У кого такая проблема встречалась? Как решили?
Помогите пожалуйста, на 2003 винде не было такого
Может требуется углубленная настройка брандмауэра, или нужно поставить какой нить модуль или патч?

Скрины брандмауэра



Скрины входящих\исходящих правил сюда непомещаються, могу отправить конфигурацию брандмаэра











Автор: DmitryPC
Дата отправки: 17-Фев-12 в 08:39
0. установить все обновления к ОС(включая сервис-паки). отключить на внешних\внутренних интерфейсах tcp ip v6, если не собираетесь его использовать.
1. попробовать определить сети в системе НЕ как общественные, а как домашние(частные).
2. попробовать отключить встроенный в систему фв.
3. попробовать оформить резервирование адресов пула на конкретные внутренние серые адреса с разрешением всех входящих.
 
PS. немного непонятен один момент: пров Вам выделил один непрерывный пул адресов или все-таки смаршрутизировал этот пул на уже существующий отдельный(ранее выданный) адрес?
если прописать один из адресов пула на внешнем интерфейсе 2к8, - инет с сервера будет?
если прописать, в дополнение к основному, на внешнем интерфейсе - вторым, любой адрес из пула, уже(!) зарезервированный на серого клиента - с клиента инет будет?


Автор: ivan101
Дата отправки: 17-Фев-12 в 08:55
надо прописать весь пул айпишников на внешнем интерфейсе сетевухи
вот так
http://imageshack.us/photo/my-images/690/ti2o.png/" rel="nofollow">

в ТИ получится вот такая картина

http://imageshack.us/photo/my-images/859/ti1k.png/" rel="nofollow">




-------------
TI 1.1.5.224 -> TI 2.0.0.644


Автор: DmitryPC
Дата отправки: 17-Фев-12 в 09:29
Исходное сообщение ivan101 ivan101 :

надо прописать весь пул айпишников ..
Так то работать будет, но должно работать и без  изврата(костыля). Возможно ТС где-то пере\недо_мудрил, и стоит попробовать перенастроить http://www.redline-software.com/rus/support/articles/networking/windows2008/windows2008r2-publish-internal-resources.php" rel="nofollow - обычным образом с нуля.


Автор: fix
Дата отправки: 17-Фев-12 в 11:35
Исходное сообщение DmitryPC DmitryPC :

0. установить все обновления к ОС(включая сервис-паки). отключить на внешних\внутренних интерфейсах tcp ip v6, если не собираетесь его использовать.
1. попробовать определить сети в системе НЕ как общественные, а как домашние(частные).
2. попробовать отключить встроенный в систему фв.
3. попробовать оформить резервирование адресов пула на конкретные внутренние серые адреса с разрешением всех входящих.
 
PS. немного непонятен один момент: пров Вам выделил один непрерывный пул адресов или все-таки смаршрутизировал этот пул на уже существующий отдельный(ранее выданный) адрес?
если прописать один из адресов пула на внешнем интерфейсе 2к8, - инет с сервера будет?
если прописать, в дополнение к основному, на внешнем интерфейсе - вторым, любой адрес из пула, уже(!) зарезервированный на серого клиента - с клиента инет будет?


0. ОС свежая с оф сайта, tcp ip v6 отключено
1. попробую, в данный момент общественные
2. отключал, но как показывает практика в моем случае, при отключенном фв он все ровно работает. может как то по хитрому его нужно отключит!?
3. пробовал

Пров. выделяет непрерывный пул
"если прописать, в дополнение к основному, на внешнем интерфейсе - вторым, любой адрес из пула, уже(!) зарезервированный на серого клиента - с клиента инет будет?"
попробую

"если прописать один из адресов пула на внешнем интерфейсе 2к8, - инет с сервера будет? "
не совсем понял

Все манипуляции буду производить в понедельник, так как сеня питница:) да и щас щлюз на 2003 работает



Автор: fix
Дата отправки: 17-Фев-12 в 11:36
Исходное сообщение ivan101 ivan101 :

надо прописать весь пул айпишников на внешнем интерфейсе сетевухи
вот так


Это конечно что то ! :)
Ну если ничего не получиться то придется так сделать

И что все работает? шлюз автоматом раздает ип клиентам? в пуле то эти все адреса прописаны?


Автор: DmitryPC
Дата отправки: 17-Фев-12 в 12:20
Исходное сообщение fix fix :

Пров. выделяет непрерывный пул
"если прописать, в дополнение к основному, на внешнем интерфейсе - вторым, любой адрес из пула, уже(!) зарезервированный на серого клиента - с клиента инет будет?"
попробую
82.151.21/26? странно, что подсеть одним скопом.
ТИ бы убрали пока(на время) совсем с этой машины - может мешать.
Исходное сообщение fix fix :

"если прописать один из адресов пула на внешнем интерфейсе 2к8, - инет с сервера будет? "
не совсем понял
это примерно то же самое, что и предложилось коллегой на предыдущей странице топика и на текущей(со скринами).


Автор: fix
Дата отправки: 17-Фев-12 в 14:38
Исходное сообщение DmitryPC DmitryPC :

Исходное сообщение fix fix :

Пров. выделяет непрерывный пул
"если прописать, в дополнение к основному, на внешнем интерфейсе - вторым, любой адрес из пула, уже(!) зарезервированный на серого клиента - с клиента инет будет?"
попробую
82.151.21/26? странно, что подсеть одним скопом.
ТИ бы убрали пока(на время) совсем с этой машины - может мешать.


ТИ и так пока не стоит


Автор: DmitryPC
Дата отправки: 17-Фев-12 в 14:44
Исходное сообщение fix fix :


ТИ и так пока не стоит
в правилах фв явно видно, что он есть(или был). ну да неважно - хозяин-барин.


Автор: fix
Дата отправки: 18-Фев-12 в 06:26
Исходное сообщение DmitryPC DmitryPC :

Исходное сообщение fix fix :


ТИ и так пока не стоит
в правилах фв явно видно, что он есть(или был). ну да неважно - хозяин-барин.

:)
во время настройки нат, его не было, потом решил поставить и сконфигурировать, и скрины фв делал уже когда ТИ стоял.
Потом снес его


Автор: fix
Дата отправки: 29-Фев-12 в 15:30
Исходное сообщение DmitryPC DmitryPC :

0. установить все обновления к ОС(включая сервис-паки). отключить на внешних\внутренних интерфейсах tcp ip v6, если не собираетесь его использовать.
1. попробовать определить сети в системе НЕ как общественные, а как домашние(частные).
2. попробовать отключить встроенный в систему фв.
3. попробовать оформить резервирование адресов пула на конкретные внутренние серые адреса с разрешением всех входящих.
 
PS. немного непонятен один момент: пров Вам выделил один непрерывный пул адресов или все-таки смаршрутизировал этот пул на уже существующий отдельный(ранее выданный) адрес?
если прописать один из адресов пула на внешнем интерфейсе 2к8, - инет с сервера будет?
если прописать, в дополнение к основному, на внешнем интерфейсе - вторым, любой адрес из пула, уже(!) зарезервированный на серого клиента - с клиента инет будет?


0. ОС свежая с оф сайта, tcp ip v6 отключено
1. поставил частные ни чего не изменилось
2. отключал, но как показывает практика в моем случае, при отключенном фв он все ровно работает. может как то по хитрому его нужно отключит!?
3. пробовал


Пров. выделяет непрерывный пул
"если прописать, в дополнение к основному, на внешнем интерфейсе - вторым, любой адрес из пула, уже(!) зарезервированный на серого клиента - с клиента инет будет?"
да инет идет

"если прописать один из адресов пула на внешнем интерфейсе 2к8, - инет с сервера будет? "
да есть

Ну все попробовал как написали.
Ситуация не изменилась


Автор: fix
Дата отправки: 29-Фев-12 в 15:34
82.151.21/26? странно, что подсеть одним скопом.
ТИ бы убрали пока(на время) совсем с этой машины - может мешать.

сеть провайдера 82.151.ХХХ.0/26
Что делать то?
Добовлять все ип выделяемые провайдером во внешнею сетевку вообще не вариант :(


Автор: DmitryPC
Дата отправки: 29-Фев-12 в 15:42
в "личку" пишите.


Автор: ivan101
Дата отправки: 01-Мар-12 в 09:10
Исходное сообщение fix fix :

Добовлять все ип выделяемые провайдером во внешнею сетевку вообще не вариант :(
почему это? я добавил, всё робит
Исходное сообщение DmitryPC DmitryPC :

в "личку" пишите.
Зачем в личку? Подскажите здесь что вы предлагаете.


-------------
TI 1.1.5.224 -> TI 2.0.0.644


Автор: DmitryPC
Дата отправки: 01-Мар-12 в 09:32
Исходное сообщение ivan101 ivan101 :

Исходное сообщение fix fix :

Добовлять все ип выделяемые провайдером во внешнею сетевку вообще не вариант :(
почему это? я добавил, всё робит
дело не в том что "робит", а в том что этот вариант НЕ подходит ТС(сами попробуйте добавить хотя бы 50 адресов... а если их будет больше?)
Исходное сообщение ivan101 ivan101 :

Зачем в личку? Подскажите здесь что вы предлагаете.
посмотреть настройки хочу для начала.


Автор: Vinsa
Дата отправки: 29-Янв-13 в 13:07
Пожалуйста, напишите, чем дело закончилось и как проблему решили. Очень нужно. Спасибо!


Автор: ivan101
Дата отправки: 29-Янв-13 в 13:19
остановился на  http://forum.smart-soft.ru/2003-server-2008-r2-enterprise_topic22012_post162035.html#162035" rel="nofollow - http://forum.smart-soft.ru/2003-server-2008-r2-enterprise_topic22012_post162035.html#162035

-------------
TI 1.1.5.224 -> TI 2.0.0.644


Автор: Vinsa
Дата отправки: 29-Янв-13 в 13:34
Спасибо за оперативный ответ :) А в разделе "маршрутизация и удаленный доступ" в пуле адресов все прописывали как и в 2003? С резервированием?
Может, тогда еще подскажете, будет ли эта схема работать, если IP меньше, чем клиентов.


Автор: ivan101
Дата отправки: 29-Янв-13 в 15:12
будет. тогда у клиента будет внешний айпи как у сервера

-------------
TI 1.1.5.224 -> TI 2.0.0.644


Автор: Vinsa
Дата отправки: 30-Янв-13 в 17:57
Связь действительно появляется. Но IP все равно у всех одинаковый, как у сервера. Даже при прописанном резервировании. Есть десяток компов, которые пользовали белые IP, выделенные конкретно им для доступа к различным гос. и не гос. ресурсам. А остальным назначались из пула любые свободные.


Автор: fix
Дата отправки: 26-Мар-14 в 12:12
подниму вопрос, такая же ситуация происходит на windows server 2012, как только добавляю пул адресов в Nat,
сервер перестает раздавать интернет, как будто что то мешает назначить внешний ip адрес внутреннему


Автор: DmitryPC
Дата отправки: 29-Апр-14 в 07:58
Исходное сообщение fix fix :

подниму вопрос...
решили б вопрос уже кардинально и не мучались... а именно: машина с ти в качестве тупого роутера без нат, натом(в любых его проявлениях) пусть занимается железка(или ОСь, которая это умеет делать без бубна от "смарт-софт"а) перед ти, как и сопоставлением белых адресов на серые, либо выдавали б пользователям сразу белые. imho.



Страница печати | Закрыть окно