Страница печати | Закрыть окно

Таймаут соединения с сервером

Распечатать форум: Форум компании Смарт-Софт
Категория: Главный раздел
Название форума: Traffic Inspector - технические вопросы.
Описание форума: Вопросы по установке, настройке, возможностям и т.п.
URL: http://forum.smart-soft.ru/forum_posts.asp?TID=24103
Дата печати: 24-Ноя-20 в 06:02
Версия ПО: Web Wiz Forums 10.14 - http://www.webwizforums.com


Тема: Таймаут соединения с сервером
Автор: Wolf1976
Тема: Таймаут соединения с сервером
Дата отправки: 08-Ноя-17 в 16:24
День добрый форумчане!
Такая проблема возникла после установки версии 3.0.2.915 фстек. Для начала хочу сказать что искал на форуме похожую ошибки и то решение мне не помогло. Переустанавливал сервер. Там работал ТИ версии 3.0.1.820. Купили новую версию и так же фильтр netpolice. Поставил, настроил все работает. Но на следующий день у некоторых компьютерах в сети начались проблемы. Агент трафик инспектора начал писать ошибку подключения: таймаут соединения с сервером. Сервер с компьютера не пинговался. Как только настройку подключения в агенте менял на http то агент писал что такого пользователя нет. Возвращал обратно на udp, все прекрасно начинает работать. Но только такое прокатило на паре компов. На одном помогло удаление пользователя и создание нового. А на другом даже это не помогает. Пишет одно и тоже. Данные переносил просто копированием папок: data и config. Вот и не могу понять где ошибка. Подскажите пожалуйста. Вынужден использовать старые агенты, поскольку в сети есть компьютеры с xp.
С уважением Роман Ильевский


-------------
Supermicro
Windows2008 R2 x64 Core I3-3220 24Gb Hdd: 1/ Raid 1 500Gb; 2. 500Gb



Ответов:
Автор: DmitryPC
Дата отправки: 09-Ноя-17 в 06:47
сам сервер то, в такие моменты, хоть "пингуется"? 
упс, не заметил.. "не пингуется", попробовать выключить внутренний фв(или обозвать внутреннюю сеть не как "публичную" при "переконфигурировании"). если поможет - сделать разрешающий фильтр на сам сервер для всех на порт авторизации, - если не поможет - хотелось бы больше данных: сеть(стурктура)\способы авторизации\используемые сервисы - может дело вовсе не в машине с ти, а в коммутационном оборудовании.. шлюз - только шлюз или нечто большее(типа файлопомойки+АД+чегототамещетипаантивируса)? 

ps. в логах ти и системы должны быть ошибки(если он(сервис ти) работает имеет к проблеме хоть какое-то отношение), - они есть?



Автор: Wolf1976
Дата отправки: 09-Ноя-17 в 07:44
Значит так. Вначале от провайдера стоит сервер на микротике х86, далее сам сервер он же и шлюз, через него идет только трафик интернета и все, так же регистрация на нем пользователей. Микротик по DHCP выдает адрес уже серверу ТИ. ТИ сконфигурирован как шлюз. Та сетевая карта, которая соединена с микротиком - публичная сеть, та что смотрит внутрь сети - локальная. После сервера ТИ стоит коммутатор и далее вся сеть. Пользователи авторизуются через агентов. Сам сервер не пингуется, что странно, даже с тех машин где все работает нормально. В настройка правила сетей убрал галку с NTLM авторизации и вроде как авторизовался один компьютер, но при этом все равно не дает доступ в интернет. 

-------------
Supermicro
Windows2008 R2 x64 Core I3-3220 24Gb Hdd: 1/ Raid 1 500Gb; 2. 500Gb


Автор: DmitryPC
Дата отправки: 09-Ноя-17 в 08:36
фв отключите - все, что на вин шлюзе.. машина с ти роутер или роутер с натом? коммутатор л2, - как я понимаю?


Автор: Wolf1976
Дата отправки: 09-Ноя-17 в 08:46
коммутатор L2/3, но работает как L2. да ти сервер с натом. а фв отключить на локальную или на публичную?

-------------
Supermicro
Windows2008 R2 x64 Core I3-3220 24Gb Hdd: 1/ Raid 1 500Gb; 2. 500Gb


Автор: DmitryPC
Дата отправки: 09-Ноя-17 в 08:53
на всё. 
если в ти есть фв - зачем использовать встроенный в систему? 
если в тике есть фв(на порядок интереснее чем в вин - imho) зачем его использовать в ти? 
если в тике есть нат(гораздо интереснее и стабильнее чем в win), какой смысл его использовать на машине с ти? 
вопросы больше риторические, - ведь ответы очевидны.

для начала хотелось бы найти откуда ноги .. для этого необходимо временно(или постоянно) отключить возможные "раздражители". с каких начинать - решать Вам. 

пинг на шлюз с клиентов должен быть без всяких проблем и без вариантов и всегда(если где-нибудь не существует специального, - запрещающего icmp, правила ) - проще "диагностировать". 


Автор: Wolf1976
Дата отправки: 09-Ноя-17 в 08:59
то есть нат в винде отрубить надо? брандмауэр ти сам отключает при установке. А машрутизацию и удаленный доступ в винде надо удалить или просто остановить сам сервер? и оставить только dhcp и dnc? микротик в данном случае выполняет роль внешнего файрвола. Так же начались такие проблемы. На конечном пользователе агент показывает что подключен, но при этом интернета нет на компьютере нет. Значек сети горит с желтым восклицательным знаком. Так же вот такая проблема. На двух машинах стоит thunderbird почтовый клиент. Машины в разных кабинетах и у них разные логины и пароли, но с одной письмо с почтового клиента уходит, а с другой нет.

-------------
Supermicro
Windows2008 R2 x64 Core I3-3220 24Gb Hdd: 1/ Raid 1 500Gb; 2. 500Gb


Автор: Wolf1976
Дата отправки: 09-Ноя-17 в 12:47
Уважаемые форумчане! Простите дурака грешного. Проблему решил. Она оказалась в том что когда настраивал DHCP с дуру ума указал в качестве шлюза не сам сервер, а адрес коммутатора. Вот и все.
Спасибо за помощь. С уважением Роман


-------------
Supermicro
Windows2008 R2 x64 Core I3-3220 24Gb Hdd: 1/ Raid 1 500Gb; 2. 500Gb


Автор: DmitryPC
Дата отправки: 09-Ноя-17 в 17:07
о как всё интересно то.. [off]линяйте в отпуск .. и срочно :) [/off]
ну почему же "с дуру", можно было и коммутатор указать .. он же l3\l2 - просто варианты способов авторизации бы уменьшились и пришлось бы стат маршруты нарисовать где надо, ну и в агентах явно прописывать адрес машины с ти.




Автор: Wolf1976
Дата отправки: 09-Ноя-17 в 19:10
Так на агентах то сервер прописан был явно. И вот в этом для меня и был затык. Вот представте кабинет разделен на 2 перегородкой. Там 2 компа. Настройки сетевые одинаковы. Но на одной машине все работает, а на другой нет. Вот и ломал голову. Пока просто внимательно не посмотрел на айпишник, который получил компьютер. И вспомнил где делал настройку

-------------
Supermicro
Windows2008 R2 x64 Core I3-3220 24Gb Hdd: 1/ Raid 1 500Gb; 2. 500Gb


Автор: DmitryPC
Дата отправки: 10-Ноя-17 в 08:40
Исходное сообщение Wolf1976 Wolf1976 :

Т... кабинет разделен на 2 перегородкой. Там 2 компа. Настройки сетевые одинаковы. Но на одной машине все работает, а на другой нет. Вот и ломал голову. Пока просто внимательно не посмотрел на айпишник, который получил компьютер. И вспомнил где делал настройку
если бы машина с ти знала где может находится пользователь(т.е. был бы стат маршрут на нужный адрес или сеть через адрес коммутатора - поскольку он являлся шлюзом для пользователя), то всё бы работало(кроме авторизации по мак адресу) .



Страница печати | Закрыть окно